03 Grand Marquis LS - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-13-13, 11:58 AM Thread Starter
Registered User
 
Join Date: Nov 2013
Posts: 1
03 Grand Marquis LS

I just recently got an 03 Grand Marquis LS with 100,000 miles on it. The radio works fine (Tape and CD), however, AM and FM have a LOT of noise and very little reception. I assumed it was the connection on the back glass or behind the radio. Both connections are solid and clean. While I had the radio out of the dash, I plugged in an external antenna I had laying around from a pontoon boat. It had the same results as the antenna in the back glass. Most of the time all I hear is static. Every now and again, I'll hear music or talking. The weirdest part, I have the radio tuned to an FM country station. But I have heard rap music, sports talk, and I have also heard the call sign for another radio station; almost as if I was changing or scanning through radio stations. Anyone ever experience anything like this?

dczysz is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-13-13, 02:36 PM
Registered User
 
Join Date: Nov 2013
Location: Baltimore,Maryland
Posts: 8
Re: 03 Grand Marquis LS

I have never seen or heard of one of these radios doing this myself. I'm assuming that you are talking about a factory Ford head unit, a.k.a a DIN radio? If so, the only thing I can think is to replace the unit and/or get a hold of another DIN radio and hook it up and see if it also does the same thing. Then you may have a better idea of whether it's the antenna or the radio itself. It shouldn't be that hard to find these in junk yards, so you can get it for cheap hopefully. DIN radios are in lots of Ford vehicles, just make sure your wire harness fits it. Maybe you could find a new/used/different wire harness from a CV/GM preferably from 03-05, to try in your GM also, might be worth checking into too.
GrandMarquis05 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome