03P71--Washed engine--problems now--Help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-18-2006, 12:16   #1 (permalink)
Registered User
 
Join Date: Sep 2006
Posts: 9
03P71--Washed engine--problems now--Help

I bought a 03 P71 with 47k miles on it last week. I had the bright idea to spray the engine with simple green and rinse it off. Everything was running fine before I did this. Anyway I was very careful to dry all plug-ins and blow off with air.
**Initially it started up with a really high idle/cel. I unplugged the battery for about an hour and restarted. The idle was normal and the engine smooth, but it is shifting incorrectely and not kicking down as normal. It also seems to be making about 70% power. These are the symptoms as of now. What do I need to do now? What have I ruined? I would appreciate all help and suggestions. I am out of ideas. Will a code reader identify whatever it is I have done? Yes I really must be stupid. Help...Help...Help...please.
Thanks, Jason
03P71alaska is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-26-2006, 15:20   #2 (permalink)
Registered User
 
dryelf327's Avatar
 
Join Date: Sep 2006
Location: Houston
Posts: 105
Re: 03P71--Washed engine--problems now--Help

These motors are notorious for coil pack issues. Had a '98 civilian Crown Vic and ran it through the car wash. As soon as the wash was over the car had a miss. #1 and #4 cylinder coil packs got moisture in them. Probably would go away with extended dry periods and then as soon as it would rain I would have issues again.
dryelf327 is offline   Reply With Quote
Old 09-26-2006, 15:21   #3 (permalink)
Registered User
 
dryelf327's Avatar
 
Join Date: Sep 2006
Location: Houston
Posts: 105
Re: 03P71--Washed engine--problems now--Help

*Correction:
(Problem) would go away with extending dry periods.
dryelf327 is offline   Reply With Quote
Old 10-16-2006, 15:21   #4 (permalink)
Registered User
 
Join Date: Sep 2006
Posts: 9
Re: 03P71--Washed engine--problems now--Help

I ruined the throttle position sensor. $190 later and all is well..no more engine washing.
jason
03P71alaska is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:25.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.