04 Crown Vic common A/C problem... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-21-2008, 21:18   #1 (permalink)
Vmc
Registered User
 
Join Date: Nov 2006
Posts: 9
04 Crown Vic common A/C problem...

Hey all....... I have an 04 CV LX with the electronic A/C....PITA.

You've PROBABLY all heard this one before, but let me run this by you.

Some time ago the A/C - VENT - DEFROSTER began cycling at a maddening rate and FINALLY now I only have DEFROST..

Give me the scoop on this, is it an automatic replacement of this damn control head, or is there another possible fix?

Vmc is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-22-2008, 10:07   #2 (permalink)
Vmc
Registered User
 
Join Date: Nov 2006
Posts: 9
Re: 04 Crown Vic common A/C problem...

Nobody?
Vmc is offline   Reply With Quote
Old 12-01-2008, 22:07   #3 (permalink)
Registered User
 
slickvic3106's Avatar
 
Join Date: Dec 2008
Posts: 20
Re: 04 Crown Vic common A/C problem...

unfortunately you probably need another ac control. its 4 7mm screws and its out. you can get them at the junkyards. 95 and up are usually the same. had the same problem. changed the unit and its been fine ever since
slickvic3106 is offline   Reply With Quote
Old 12-02-2008, 08:08   #4 (permalink)
Vmc
Registered User
 
Join Date: Nov 2006
Posts: 9
Re: 04 Crown Vic common A/C problem...

Quote:
Originally Posted by slickvic3106 View Post
unfortunately you probably need another ac control. its 4 7mm screws and its out. you can get them at the junkyards. 95 and up are usually the same. had the same problem. changed the unit and its been fine ever since
Thanks slick....I was hoping someone would chime in...I KNOW this is a COMMON problem...good ol Ford quality and all.

I WAS hoping to hear someone tell me " well, 90% of the time, it's just a vacuum line or an INEXPENSIVE control motor", but I'm resigned to the probability that it's that TOTALLY EXPENSIVE control head......


Thanks for chiming in!!

Dan.
Vmc is offline   Reply With Quote
Old 12-04-2008, 21:56   #5 (permalink)
Registered User
 
slickvic3106's Avatar
 
Join Date: Dec 2008
Posts: 20
Re: 04 Crown Vic common A/C problem...

its actually not that expensive if you go to a pull it yourself junkyard. when i worked at one it was only 15 dollars.
slickvic3106 is offline   Reply With Quote
Old 12-04-2008, 22:36   #6 (permalink)
Vmc
Registered User
 
Join Date: Nov 2006
Posts: 9
Re: 04 Crown Vic common A/C problem...

Quote:
Originally Posted by slickvic3106 View Post
its actually not that expensive if you go to a pull it yourself junkyard. when i worked at one it was only 15 dollars.
THANKS!! Question tho.... I've never pulled one of these out, so how does it come out? Does the panel just snap in? Do I need any specific tools to change one out?

THANKS AGAIN!!
Vmc is offline   Reply With Quote
Old 12-07-2008, 23:06   #7 (permalink)
Registered User
 
slickvic3106's Avatar
 
Join Date: Dec 2008
Posts: 20
Re: 04 Crown Vic common A/C problem...

its easy. real simple. pull the dash panel off. the part that runs the length of the dash. and then there are 4 7mm screws holding it in. take those off and it should pull out. now on the back there are 4 plugs that snap off and the vaccuum lines that are usually held on with a 10mm nut. take those off and pull the lines off and you got it out. hope that was clear enough. good luck man. let me know how it works out
slickvic3106 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:29.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.