1990 crown vict. wagon - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-01-06, 08:15 AM Thread Starter
Registered User
 
Join Date: Sep 2006
Posts: 14
1990 crown vict. wagon

hi,
whenever i drive quite a bit, upon stopping at a light i hear a banging noise coming from the engine. I believe it has something to do with the coolant getting hot. i felt the upper large coolant hose and felt it hot and pulsing.
would anyone know why i hear this banging noise when coolant gets hot. the car never overheats and rides smoothly. is it possible i have to change my thermostat?
any help would be greatly appreciated.
thank you
newyorker is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-06-06, 09:30 AM
Registered User
 
Freshmeat's Avatar
 
Join Date: Sep 2005
Location: Geismar, LA, USA
Age: 32
Posts: 833
Re: 1990 crown vict. wagon

Can you better describe the banging?
Freshmeat is offline  
post #3 of 3 (permalink) Old 09-06-06, 04:46 PM Thread Starter
Registered User
 
Join Date: Sep 2006
Posts: 14
Re: 1990 crown vict. wagon

I can't really describe the banging sound, I know its when the car is driven quite a bit and then upon stopping you hear it. I don't know whether it's coming from the thermostat or possibly the heater core. I had tested the coolant mixture and it is fine. I had also ran the heater of the car in case any air was in the coolant system. Any ideas would be greatly appreciated.
thank you
newyorker is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome