1990 Grand Marquis Trouble or not? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-12-08, 06:51 AM Thread Starter
Registered User
Join Date: Jan 2008
Posts: 3
1990 Grand Marquis Trouble or not?

I have a 1990 Grand Marquis that was my grandparents. They have been gone for quite a while now and the car has been sitting more than it has been drove. In the past 10 years it has had about 2000 miles put on it. I decided to take it and start driving it. It has a few issues that maybe you can help with.

I drove it around town and it done okay, but my speed didnt go over like 20 mph. I drove it faster and found out that it doesnt shift into 3rd and when you put it in overdrive it is like neutral. You put it in D and it is just 1 and 2 gears. Dont know if it was like this before they passed away or not.

The slide switch to adjust the temperature for the climate control is real loose. You try to push it to the extreme left or right and the button flips off. Its like it has excessive hinge like feeling.

There is a hole in a pipe that is behind the check valve for the AIR system. It looks like it goes to the back of the head. Do they make these aftermarket or what is the best approach?

I forgot to add that it has 80,000 miles.


youbetcha77 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 02-03-08, 08:50 PM
360ci's Avatar
Join Date: Nov 2007
Location: Waterloo
Posts: 2,479
Re: 1990 Grand Marquis Trouble or not?

I'd change out the transmission fluid. 10 years is a long time to go without a change, regardless of mileage. If anything else, the old fluid tarnished and left a film over the gears in the tranny (not good). Same with the engine oil if you haven't done so already. Drive around in first/2nd gear and keep the rpms up (after oil change and new spark plugs!) it may require another tranny service within a few thousand miles just to make sure all the crap is out, if the transmission still misses shifts then I'm sure it will require a rebuild.

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome