1993 Grand Marquis - terrible idle. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 11-19-10, 04:45 PM Thread Starter
Registered User
 
Join Date: Nov 2010
Posts: 4
1993 Grand Marquis - terrible idle.

My car has a couple serious problems. First of all, when it's been sitting for more than seven hours and I go to start it, it will want to die immediately when it starts. I have to feather the throttle for about six-seven minutes before it will idle without dying.

Secondly, it idles very roughly. When it's been sitting for ANY period of time, even just at a stop light, it will start to idle very roughly, slightly jerky. The idle will often go from slightly normal to badly low. When I start it after it's been off, even for a few minutes, if I try to set off with it without revving it for a couple minutes, I'll have basically no throttle response, and the engine will jerk badly. I have to mash the accelerator, and it will act like fuel isn't getting into the cylinders. Often, it will also make an alarming popping noise from under the hood. I'll have to keep the accelerate mashed for a good 5, 10 seconds before it will pick back up and smooth out.

What's the source(s) of my problems?

LunaVyohr is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 11-19-10, 05:05 PM
Pantherholic
 
87_Crown_Vic's Avatar
 
Join Date: Apr 2009
Location: Omaha, NE
Age: 36
Posts: 376
Garage
Re: 1993 Grand Marquis - terrible idle.

when was last time car had plugs and wires? also fuel filter would be good thing to do ... those are things i need to know... and if that stuff is current, i would be guessing the IAC is gummed up with oil and gunk and needs cleaned


my 1986 Grand Marquis LS... Rose...
87_Crown_Vic is offline  
post #3 of 7 (permalink) Old 11-19-10, 05:11 PM Thread Starter
Registered User
 
Join Date: Nov 2010
Posts: 4
Re: 1993 Grand Marquis - terrible idle.

Just changed the fuel filter. Wires are good, plugs I'm not sure - if the state of the wires are to be believed, they are good as well but I haven't checked them.
LunaVyohr is offline  
post #4 of 7 (permalink) Old 11-19-10, 05:54 PM Thread Starter
Registered User
 
Join Date: Nov 2010
Posts: 4
Re: 1993 Grand Marquis - terrible idle.

I should mention that when I'm revving it, trying to get it toidle without dying, sometimes I'll feather it a bit and when I let off, the throttle will stay as if I'm still revving it. Could one of my idle problems be a vacuum leak?
LunaVyohr is offline  
post #5 of 7 (permalink) Old 11-19-10, 06:17 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,340
Re: 1993 Grand Marquis - terrible idle.

As 87_Crown_Vic mentioned, the IAC could need cleaning. Unplug the MAF and see how it runs too.

Bert
Bert is offline  
post #6 of 7 (permalink) Old 11-19-10, 07:06 PM Thread Starter
Registered User
 
Join Date: Nov 2010
Posts: 4
Re: 1993 Grand Marquis - terrible idle.

What's the best way to clean an IAC?
LunaVyohr is offline  
post #7 of 7 (permalink) Old 11-19-10, 08:18 PM
Pantherholic
 
87_Crown_Vic's Avatar
 
Join Date: Apr 2009
Location: Omaha, NE
Age: 36
Posts: 376
Garage
Re: 1993 Grand Marquis - terrible idle.

i have used carb cleaner to clean it out... i spray some in the IAC and plug the holes with my hand and shake it up good... i dump it out then spray it again to rinse what didnt pour out after shaking


my 1986 Grand Marquis LS... Rose...
87_Crown_Vic is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome