1998 GM speedometer problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-13-12, 04:31 AM Thread Starter
Registered User
 
Join Date: Mar 2012
Posts: 15
Lightbulb 1998 GM speedometer problem

My speedometer and odometer stopped working at 106500. The cruise controll still works so it is most likely not the vss. I put a used clusterin but had the same problem. all instruments work except for speedo and odometer. Any sugestions?

thebeebs is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-13-12, 12:07 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,326
Re: 1998 GM speedometer problem

Look at the printed circuit board in the cluster to see if there are any breaks. Also, check the cruise control servo and lighting control connections.

Bert
Bert is offline  
post #3 of 6 (permalink) Old 03-14-12, 04:18 PM Thread Starter
Registered User
 
Join Date: Mar 2012
Posts: 15
Re: 1998 GM speedometer problem

This is interesting since i just lost my automatic dome lights. They do turn on manually, just not on open door.
thebeebs is offline  
post #4 of 6 (permalink) Old 03-14-12, 05:18 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,326
Re: 1998 GM speedometer problem

Is that with every door?

Bert
Bert is offline  
post #5 of 6 (permalink) Old 03-07-14, 09:31 PM Thread Starter
Registered User
 
Join Date: Mar 2012
Posts: 15
Re: 1998 GM speedometer problem

yes bert , with every door. the rear courticy lights work just not the center dome light. Yes two years with no speedo. thank god for gps. Is there a speed sensor other than the VSS. ABS not equipt.
thebeebs is offline  
post #6 of 6 (permalink) Old 09-15-14, 01:49 AM Thread Starter
Registered User
 
Join Date: Mar 2012
Posts: 15
Re: 1998 GM speedometer problem

found out that speedo/odometer have seperate power from the resr of the cluster. I was getting no keyed power. I just jumped a keyed power wire to the speedo wire. Voila..low milage GM
thebeebs is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome