1999 FORD CROWN VICTORIA P-71 POLICE INTERCEPTOR ... Electronic 0-140 MPH speedometer - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-04-2009, 04:33   #1 (permalink)
Registered User
 
Join Date: Dec 2008
Location: england
Posts: 8
1999 FORD CROWN VICTORIA P-71 POLICE INTERCEPTOR ... Electronic 0-140 MPH speedometer

does anyone know whats up with my speedo,it seems to of stopped working,there is no trip,no speedo,no miles working on it.

i have a 1999 crown victoria p71

is there a fuse that controls the speedo.

everything else works exept rear window defrost.

can somebody help as i dont have a manual for this car and dont know which fuse controls the speedo
nova2727 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-04-2009, 08:06   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,702
Re: 1999 FORD CROWN VICTORIA P-71 POLICE INTERCEPTOR ... Electronic 0-140 MPH speedom

It's fuse #15 under the dash but controls all the gauges. It might be the vehicle speed sensor on the rear of the transmission.
Bert is offline   Reply With Quote
Old 10-04-2009, 11:45   #3 (permalink)
Registered User
 
Join Date: Dec 2008
Location: england
Posts: 8
Re: 1999 FORD CROWN VICTORIA P-71 POLICE INTERCEPTOR ... Electronic 0-140 MPH speedom

thanks for the info,could be the sensor after all.

as the only thing not working is the miles,trip.part of the speedo.

is the sensor easy to fit if i was to do myself,or better take it to ford
nova2727 is offline   Reply With Quote
Old 10-04-2009, 12:02   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,702
Re: 1999 FORD CROWN VICTORIA P-71 POLICE INTERCEPTOR ... Electronic 0-140 MPH speedom

If only the miles trip isn't working, the VSS isn't the problem. It would be the speedometer itself. If the needle doesn't move either, the VSS is more than likely the problem. Here's a picture of the location. They are easy to replace. You might get a VERY minimal amount of fluid leak taking it out.
Attached Images
File Type: jpg VSS.jpg (57.7 KB, 10 views)
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 12:54.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.