2003 Crown Vic goes neutral in OD - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-30-12, 09:07 AM Thread Starter
Registered User
 
Join Date: Jan 2012
Location: Lakeland, FL
Posts: 1
2003 Crown Vic goes neutral in OD

New member here. My AOD-E goes into neutral when it upshifts to over drive. It shifts fine up to 3rd gear. If I disengage the OD, drives fine. Happened with out warning. Drove car all day, parked it for two hours, when I drove off afterward, I noticed the engine rev like a sliping clutch. I've read some on the MLPS, manual lever position sensor and wonder if any of you have heard of this issue. Recommendations? Warm in Florida.

tpa97i is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-30-12, 09:32 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,311
Re: 2003 Crown Vic goes neutral in OD

Has the trans been serviced regularly? When was the last time and how was it done?

Bert
Bert is offline  
post #3 of 4 (permalink) Old 02-07-12, 12:46 PM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: 2003 Crown Vic goes neutral in OD

Sounds like a low fluid condition. If the fluid is low, top it up accordingly and take it to a shop. I had similar conditions on my older Taurus. Found out a seal went ($400). However, you have it decent, I started the car put it in drive and the gears wouldn't even catch it was so low on fluid.

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
post #4 of 4 (permalink) Old 02-08-12, 12:16 PM
Registered User
 
Den49's Avatar
 
Join Date: Nov 2011
Posts: 18
Re: 2003 Crown Vic goes neutral in OD

Earlier generation car, but I had the same thing occur to a 1990 CV. The overdrive lockup torque converter needed to be replaced. Cost $1,200.00 in year 2000.
Den49 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome