2005 CVPI 85000 miles brake light comes on but brakes work??? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 03-04-14, 06:52 PM Thread Starter
Registered User
 
Join Date: Mar 2014
Posts: 86
2005 CVPI 85000 miles brake light comes on but brakes work???

Can any one help...??

2005 P71

when you set on brake pedal the light comes on and goes off when you let up on pedal
should that be throwing a code????

what do you think it is? brakes work!!


any help would be great... thanks

Truckie256 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 03-05-14, 04:04 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,917
Re: 2005 CVPI 85000 miles brake light comes on but brakes work???

Checked brake fluid level ?
R.S.LOGAN is offline  
post #3 of 15 (permalink) Old 03-05-14, 04:16 AM
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 1,960
Re: 2005 CVPI 85000 miles brake light comes on but brakes work???

Agree with R.S. Check brake fluid. When you step on the pedal the level will go down slightly. If low time to check brakes pads could be getting thin.


Sent from AutoGuide.com App
r-clar is offline  
post #4 of 15 (permalink) Old 03-05-14, 09:08 AM Thread Starter
Registered User
 
Join Date: Mar 2014
Posts: 86
Re: 2005 CVPI 85000 miles brake light comes on but brakes work???

will check fluid level tomorrow when going over car pre purchase..

he says his mechanic says right front ABS sensor and online research tells me it could be ABS module..... someone said possible master cyl. getting ready to go bad.....
Truckie256 is offline  
post #5 of 15 (permalink) Old 03-05-14, 09:18 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,917
Re: 2005 CVPI 85000 miles brake light comes on but brakes work???

If you haven't bought the car , leave it up to the seller to fix before the sale goes through .
R.S.LOGAN is offline  
post #6 of 15 (permalink) Old 03-05-14, 12:08 PM Thread Starter
Registered User
 
Join Date: Mar 2014
Posts: 86
Re: 2005 CVPI 85000 miles brake light comes on but brakes work???

plan on fixing it myself once I own it...

getting clean 85000 mile CVPI that was a transport car not cruiser with corner strobes, center console, new AC condenser and service records from the dept that owned it.. for $3000

State Farm will give me $5800 if I total it out on the way home... as long as it drives well and no crazy issues found I am not worried...

my last CVPI was a 2000 from California highway patrol and I bought it online without ever really seeing it or driving it and it was an awesome car...

already verified that ford will do the steering recall

I am just trying to research what issue could be so I can attack it with a purpose.. and save a few bucks.
Truckie256 is offline  
post #7 of 15 (permalink) Old 03-05-14, 12:16 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,917
Re: 2005 CVPI 85000 miles brake light comes on but brakes work???

As r-clar also suggested , if pads are low down , the fluid in master cyl drops .This allows fluid movement which can trigger the warning light on braking , but other possible causes .If that is all that is needed , not a big problem or cost .
R.S.LOGAN is offline  
post #8 of 15 (permalink) Old 03-05-14, 01:18 PM
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 6,815
Re: 2005 CVPI 85000 miles brake light comes on but brakes work???

I don't think it would be a ABS issue. Generally that would illuminate the ABS lamp instead of the Brake lamp. As stated above, its more than likely low on fluid or could even be a failing master cylinder as you stated. When driving does the brake peddle seem to go down further than it should?
jwko is offline  
post #9 of 15 (permalink) Old 03-05-14, 06:23 PM Thread Starter
Registered User
 
Join Date: Mar 2014
Posts: 86
Re: 2005 CVPI 85000 miles brake light comes on but brakes work???

will find out tomorrow but he told me he just put 2 tires on it and brakes all the way around with the alignment... service records indicate it slid into a ditch on ice and the front bumper was replaced.... I work at Advance Auto parts for my 2nd job so parts and help are available.

I have to replace the AC condenser too as he poked hole in it messing with siren speaker brackets...

gonna check fluid and clean the sensor on that wheel first
Truckie256 is offline  
post #10 of 15 (permalink) Old 03-06-14, 05:02 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,917
Re: 2005 CVPI 85000 miles brake light comes on but brakes work???

Dont suppose that car has pad wear sensors fitted ? Make sure the tyres fitted are correct or could trigger ABS .Depending on how bad going into the ditch , but make sure nothing bent especially after having to get alignment / tracking done and tyres replaced ..
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome