2005 Ford Crown Victoria heat won't blow - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-26-13, 12:32 PM Thread Starter
Registered User
 
Join Date: Mar 2013
Posts: 6
Arrow 2005 Ford Crown Victoria heat won't blow

I recently purchased a used 05 Crown Victoria. The heating system worked when I first got it but after a few days it stopped blowing. I tried replacing the control panel and the blower. Neither of those were a resolution. I had it straight wired so that I could have some type of heat and it worked however I can't control the temp nor how hard the fan blows so I had it disconnected. One thing I have not done is checked the fuses...cause I don't know which fuse is for the heat!!! Please help!

BlackDiamond is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-26-13, 03:34 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,860
Re: 2005 Ford Crown Victoria heat won't blow

F2.2,The fuse panel is located below and to the left of the steering wheel by the brake pedal. Remove the panel cover to access the fuses.To remove a fuse use the fuse puller tool provided on the fuse panel cover. Here's a link for the first publication of the service manual: http://www.motorcraftservice.com/pub.../05croog1e.pdf

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
post #3 of 6 (permalink) Old 03-26-13, 04:03 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,311
Re: 2005 Ford Crown Victoria heat won't blow

Does the fan blow on high?

Bert
Bert is offline  
post #4 of 6 (permalink) Old 04-11-13, 06:24 PM Thread Starter
Registered User
 
Join Date: Mar 2013
Posts: 6
Re: 2005 Ford Crown Victoria heat won't blow

Bert,
No it does not blow. I can't control the temperature nor the fan. The only heat I get is from the motor when the vents are open.
BlackDiamond is offline  
post #5 of 6 (permalink) Old 04-12-13, 08:07 AM
Moderators
 
Join Date: Jul 2011
Posts: 691
Re: 2005 Ford Crown Victoria heat won't blow

Do you have the automatic HVAC control head (with the digital readout), or the manually set control?
Bajarider is offline  
post #6 of 6 (permalink) Old 04-13-13, 10:59 AM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,860
Re: 2005 Ford Crown Victoria heat won't blow

Since your fan doesn't work in any speed, it sounds like a power loss. If your fuses are good, you need to check and see if you have power to the fuse and power to the blower relay. You might have a bad relay.

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome