2005 Ford Crown Victoria won't pass emissions - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-26-2013, 13:24   #1 (permalink)
Registered User
 
Join Date: Mar 2013
Posts: 6
Exclamation 2005 Ford Crown Victoria won't pass emissions

I recently purchased a used 2005 Ford Crown Victoria. Check engine light came on after 3 days. The light went off and then came back on after 2 days. Took the car through inspection and it failed the emissions test. I was told to try fuel injector cleaner and take it back through inspection. I did that and the emissions reading was worse than the first time. The codes were P0193/Fuel Rail Pressure Sensor A Circuit High and P0430/Catalyst System Efficiency Below Threshold Bank 2. I don't want to be taken advantage of because I'm a female and have no mechanical knowledge. Any helpful advice as to how I can get my car to pass emissions without it being too costly?
BlackDiamond is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-26-2013, 16:13   #2 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 4,026
Re: 2005 Ford Crown Victoria won't pass emissions

The first one says that you're not getting enough fuel, and the second one is saying that your O2 sensor on the drivers side exhaust downstream of the catalytic converter thinks your cat's not functioning anymore. Since you don't have a lean code (also caused by insufficient fuel), you probably need a fuel filter, checking fuel pressure with the proper tool (cost about 50 bucks) will confirm pressure or bad sensor.

The O2 sensor will require a multimeter and electrical testing.
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Old 04-11-2013, 19:39   #3 (permalink)
Registered User
 
Join Date: Mar 2013
Posts: 6
Arrow Re: 2005 Ford Crown Victoria won't pass emissions

I appreciate your answer...sounds like you really know your stuff but could you break that down just a little bit more...so a "girl" could relay this to a mechanic?
BlackDiamond is offline   Reply With Quote
Old 04-12-2013, 09:04   #4 (permalink)
Moderators
 
Join Date: Jul 2011
Posts: 571
Re: 2005 Ford Crown Victoria won't pass emissions

'so a "girl" could relay this to a mechanic'?

Hey Cat, I can't wait to hear how you handle this one!
Bajarider is offline   Reply With Quote
Old 04-13-2013, 11:37   #5 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 4,026
Re: 2005 Ford Crown Victoria won't pass emissions

Quote:
Originally Posted by BlackDiamond View Post
I appreciate your answer...sounds like you really know your stuff but could you break that down just a little bit more...so a "girl" could relay this to a mechanic?
Thanks for the compliment, but I'm really not that good, just been hanging around here a while now.

I had my wife read this for a womanly interpretation and she looked at me and batter her eyes and said "Excuse me, but my little thingy under the hood isn't working right, can you help me?"

Since that didn't work out so well (she barely knows how to put gas in it, with proof from the fact that our car is always on "E" when I go to drive it), try this: Change the fuel filter and you may need an O2 sensor.
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Old 04-13-2013, 11:38   #6 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 4,026
Re: 2005 Ford Crown Victoria won't pass emissions

Quote:
Originally Posted by Bajarider View Post
'so a "girl" could relay this to a mechanic'?

Hey Cat, I can't wait to hear how you handle this one!
Baja, thank you for the vote of confidence. You, my dear friend, are cordially invited to bite the hairiest part my my buttocks.
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Old 04-13-2013, 14:14   #7 (permalink)
Registered User
 
Join Date: Mar 2013
Posts: 6
Thumbs up Re: 2005 Ford Crown Victoria won't pass emissions

Thanks Cat Skinner! I don't know much about the mechanics of a car but I do know a little about the fuel filter and O2 sensor.

Baja...CatSkinner did an awesome job!
BlackDiamond is offline   Reply With Quote
Old 04-13-2013, 18:21   #8 (permalink)
Moderators
 
Join Date: Jul 2011
Posts: 571
Re: 2005 Ford Crown Victoria won't pass emissions

Yes Black Diamond, he did, but I think his wife made him do it.
Seriously, stick around here and we'll always try to help.
Oh, and thanks Cat, but I'll pass on your invitation. Your's probably has as many chunks missing as mine. I always "step in it" when trying to explain anything mechanical to my wife and I just couldn't wait to see how you handled it. Good job!
Bajarider is offline   Reply With Quote
Old 04-14-2013, 11:36   #9 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 4,026
Re: 2005 Ford Crown Victoria won't pass emissions

I don't even try to explain it to her any more, I just tell her it's broke or that I fixed it.
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Old 04-15-2013, 08:28   #10 (permalink)
Moderators
 
Join Date: Jul 2011
Posts: 571
Re: 2005 Ford Crown Victoria won't pass emissions

Good advice!
Bajarider is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 08:22.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.