84 Grand Marquis not starting - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-15-08, 10:38 AM Thread Starter
Registered User
 
Join Date: Jul 2008
Posts: 2
84 Grand Marquis not starting

I have a 84 Grand Marquis that is not starting. It is getting spark and fuel but all it dose is turn over kind of slow. What it did is I was driving it and it just died and would not start again.

maxteca is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-15-08, 06:07 PM
Registered User
 
Join Date: Jul 2003
Location: texas
Age: 56
Posts: 97
Re: 84 Grand Marquis not starting

I would check you ignition system. I dont know what you have for that year, but a book for that year could be found at autozone and tell you more about that.
art
mercdriver is offline  
post #3 of 3 (permalink) Old 07-15-08, 06:55 PM Thread Starter
Registered User
 
Join Date: Jul 2008
Posts: 2
Re: 84 Grand Marquis not starting

Quote:
Originally Posted by mercdriver View Post
I would check you ignition system. I dont know what you have for that year, but a book for that year could be found at autozone and tell you more about that.
art
I did that I put in new cap and rotor, plugs and coil.
maxteca is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome