86 Crown Help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-16-05, 09:51 AM Thread Starter
Registered User
 
Join Date: Aug 2005
Posts: 3
frown 86 Crown Help

My a 86 Crown Victoria starts fine but misses a little then it will die after a couple minutes of running. Starts back up fine. When driving I get to around 35 MPH and going up hill or down and try to accelerate it gets a jerking motion, and it sounds to me like a miss in the engine, but if I put the peddel to the floor it takes off and runs great.
I have had it to my mechanic but he couldn't find the problem, recomended that I use higher octane fuel. And I do but is hasn't helped.
I have new , points, rotor, condensor, plug wires, new exaust system front to back. any help will be appriciated

What I forgot to mention in my first message. It has 88,000 miles on this car, and I also have to press the foot pedal up and down fast to get it to go after a stop. and taking off after going around a corner.
[Edit]
86crown is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-16-05, 12:50 PM
Tremec Masher
 
GrandMarquisGT's Avatar
 
Join Date: Aug 2005
Age: 33
Posts: 62
Re: 86 Crown Help

I think yo may have a bad TFI module. They get hot and start messing up when they are bad...

Your vehicle shouldnt have points and condensor.

GrandMarquisGT is offline  
post #3 of 4 (permalink) Old 08-16-05, 06:19 PM
no longer yo *********!!
 
1987LTDmasta's Avatar
 
Join Date: Aug 2005
Location: lost in Chicago, IL.
Age: 33
Posts: 40
Re: 86 Crown Help

Quote:
Originally Posted by GrandMarquisGT
I think yo may have a bad TFI module. They get hot and start messing up when they are bad...

Your vehicle shouldnt have points and condensor.

i second the TFI module


also check your base timing. could be off a few degrees

1987LTDmasta is offline  
post #4 of 4 (permalink) Old 08-18-05, 10:50 PM
That guy
 
BlueSteel's Avatar
 
Join Date: Jul 2004
Location: Belleville michigan
Age: 29
Posts: 389
Re: 86 Crown Help

TFI? Isn't that the module on the distributor? Hmm, I just replaced the hole thing with a MSD :) Runs better :)

Blue Anodized Steel
The Apocalypse is coming, are you ready?

BlueSteel is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome