88 Crown Vic 5.0 rough idle - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-09-07, 01:58 PM Thread Starter
Registered User
 
Join Date: Nov 2007
Posts: 8
88 Crown Vic 5.0 rough idle

I am new here, so sorry if I should have searched more for my answers. I recently bought a 88 Crown vic with the 5.0L and 80,xxx miles. As far as I know, the car sat in a garage for a while before I bought it. First thing I did was change the oil and filter, then air filter, then plugs, wires, cap & rotor, and fuel filter. If I come to a stop and change gears (from drive to reverse, etc) it stumbles a little. It is much better than it was, but I would like it better yet. It idles a little rough when in park idling, cold or warm. Any thoughts on what else to check? Thanks in advance.
mmmdiesel is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-29-08, 11:44 PM
Registered User
 
Join Date: Feb 2008
Posts: 4
Re: 88 Crown Vic 5.0 rough idle

Quote:
Originally Posted by mmmdiesel View Post
I am new here, so sorry if I should have searched more for my answers. I recently bought a 88 Crown vic with the 5.0L and 80,xxx miles. As far as I know, the car sat in a garage for a while before I bought it. First thing I did was change the oil and filter, then air filter, then plugs, wires, cap & rotor, and fuel filter. If I come to a stop and change gears (from drive to reverse, etc) it stumbles a little. It is much better than it was, but I would like it better yet. It idles a little rough when in park idling, cold or warm. Any thoughts on what else to check? Thanks in advance.

I had a 1988 Crown Victoria with the same problem. I know this is quite a bit older but the problem with that vehicle was a part called the idle control arm. Once that was replaced the vehicle ideled like new. If it weren't for needing a quart of oil every 2 days I would never have upgraded the my 2006.

There is also a valve that was changed. Not the EGR valve. e-mail me to remind me when I get home to look up the valve that was changed. This should solve your problem.

vanessa@tv-nbc.com<!-- google_ad_section_end --><!-- / message -->
Vanessa2008 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome