89 Vic No Start - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-26-2012, 17:59   #1 (permalink)
Registered User
 
00Silver's Avatar
 
Join Date: Oct 2011
Location: NE OHIO
Posts: 251
89 Vic No Start

My mother in law's 89 vic decided to leave her stranded at the grocery store tonight. The car drove fine all day, and when she went to leave from the grocery store, she turned the key and nothing happens. She has no headlights, tail lights, dash lights, dome light etc... Turns the key and its dead silent. When the tow truck gets it home, I'm going to start with the obvious and check the battery and cable connections. Can anyone think of anything else I should look for? Never had any issues with this car in the year that she's had it, and if I remember correctly, the battery is only a month or 2 old....
00Silver is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-26-2012, 18:42   #2 (permalink)
Registered User
 
00Silver's Avatar
 
Join Date: Oct 2011
Location: NE OHIO
Posts: 251
Re: 89 Vic No Start

Batt. terminals were severely corroded and the ground wire is chaffed in a couple spots...got her fired up after cleaning the terminals. Changing ground wire tomorrow. Thanks anyways guys
00Silver is offline   Reply With Quote
Old 09-27-2012, 06:07   #3 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 10,031
Re: 89 Vic No Start

You got it fixed before any one could reply . Glad you got it fixed and it was relatively simple , thanks for update .
R.S.LOGAN is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:23.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.