90 Crown vic , Horn Relay , Horn Issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-21-10, 11:15 AM Thread Starter
Registered User
 
90capeLtd's Avatar
 
Join Date: Nov 2009
Posts: 36
90 Crown vic , Horn Relay , Horn Issues

hi all , been having trouble with my horn for months now , will work on and off but never when i need it ! under the hood theres a little black box im guessing is the relay for the horn , i can hear it clicking when ever i hit the horn button but nothing from the horn it self . any ideas what it could be ?
90capeLtd is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-21-10, 05:16 PM
Registered User
 
tbird100636's Avatar
 
Join Date: Jan 2005
Location: Massachusetts
Age: 33
Posts: 1,833
cool Re: 90 Crown vic , Horn Relay , Horn Issues

Quote:
Originally Posted by 90capeLtd View Post
hi all , been having trouble with my horn for months now , will work on and off but never when i need it ! under the hood theres a little black box im guessing is the relay for the horn , i can hear it clicking when ever i hit the horn button but nothing from the horn it self . any ideas what it could be ?
Did the horns seem weak when they worked??? Find the horns and using a test light hooked to ground, checked for power at the horns when operating the switches. If it is present on both horn wires next check the ground side. Clip the test light to power. Touch the test light to the metal body or bracket of horns. It should light. If the test light illuminates both times for both horns then you have bad horns.

Master ASE Certified L1 Chrysler Technician- still a Ford fan at heart.
1964 Thunderbird Hardtop- Chantily Beige- 390 FE 4V V8-Uncle's Car
1966 Thunderbird Convertible- Red- 390 FE 4V V8- Uncle's other car- waiting for paint and body work!!!
tbird100636 is offline  
post #3 of 3 (permalink) Old 11-21-10, 05:22 PM Thread Starter
Registered User
 
90capeLtd's Avatar
 
Join Date: Nov 2009
Posts: 36
Re: 90 Crown vic , Horn Relay , Horn Issues

ok will do , the horns didnt seem weak when they did work. thanks for the tips though

ellis
90capeLtd is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome