92 vic mechanical probs - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 04-17-06, 08:53 PM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 14
92 vic mechanical probs

ok my 92 is having problems it will idle and cut off. cuts off even quicker if a/c is on. also it will stall on take off i hitthe gas and it bogs down then all of a sudden shoot off. i put on a iac from the junkyard i cleaned it with some deep creep. i replaced plugs and air filter need some help. it also idles very weirdly it is very spurratic up and down. some one told me it was the tps. i really want to get my car right i need help

92VICMEM is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 04-18-06, 12:04 PM
Registered User
 
Join Date: Dec 2003
Posts: 160
Re: 92 vic mechanical probs

I would also replace the fuel filter. And a way to check to make sure your IAC is working is to unplug it while the car is at idle and if the car stalls then the IAC is working like it should, Because cleaning a IAC does not always work so they are replaced rather than cleaned. I would check the voltage at the TPS sensor it should read .5-1 volt at idle and at WOT 4-5 volts. I would also think about cleaning your MAF sensors.
amo4387622 is offline  
post #3 of 10 (permalink) Old 04-18-06, 03:59 PM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 14
Re: 92 vic mechanical probs

i replaced fuel filter i forgot to mention it stalls out alot.
92VICMEM is offline  
post #4 of 10 (permalink) Old 04-20-06, 12:12 PM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 14
Re: 92 vic mechanical probs

ok i changed tps doesnt bog down anymore but it can hardly idle it'll sit there for a sec then just die. could that be the iac valve
92VICMEM is offline  
post #5 of 10 (permalink) Old 04-20-06, 07:50 PM
Registered User
 
Join Date: Dec 2003
Posts: 160
Re: 92 vic mechanical probs

I would replace the IAC with a new one.
amo4387622 is offline  
post #6 of 10 (permalink) Old 04-20-06, 08:46 PM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 14
Re: 92 vic mechanical probs

bought an iac gonna put on in the morn and c what happens
92VICMEM is offline  
post #7 of 10 (permalink) Old 04-23-06, 06:27 PM
Registered User
 
Join Date: Dec 2005
Posts: 24
Re: 92 vic mechanical probs

Quote:
Originally Posted by 92VICMEM
bought an iac gonna put on in the morn and c what happens
I had the same problem on my 1994 CV. It was a Vaccum line T on the top of the motor underneath the intake toware the rear. The T leaked right wear the injector nipple was to mold the rubber. Over time these rubber couplers just dry up and start to crack. I would check or replace them first. It is a cheaper fix first. You could do a vacuum check also. That would tell you if you are having a vacuum problem.
ajone825 is offline  
post #8 of 10 (permalink) Old 04-24-06, 08:16 AM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 14
Re: 92 vic mechanical probs

thanks i just replaced my fuel pump and the iac. the car doesnt cut off anymore but i noticed something it only runs when the maf is off when its on the car runs crappy so im assuming the mafs is bad
92VICMEM is offline  
post #9 of 10 (permalink) Old 04-24-06, 10:00 AM
Registered User
 
Join Date: Dec 2003
Posts: 160
Re: 92 vic mechanical probs

That does not mean the MAF is bad it might just need to be cleaned. Go to and autoparts store and ask them what they have for a spray to clean the MAF because I forget what to use. Because I have heard people using TB cleaner or a can of compressed air also.
amo4387622 is offline  
post #10 of 10 (permalink) Old 04-24-06, 06:24 PM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 14
Re: 92 vic mechanical probs

i just found out that theres a reset button in the trunk for the fuel pump and it pops up from time to time and it causes my car to cut off
92VICMEM is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome