'93 Grand Marquis Audio Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-04-2005, 21:07   #1 (permalink)
Registered User
 
Join Date: Oct 2005
Posts: 1
'93 Grand Marquis Audio Problem

So, heres the story. Driving down the road and I hear a few pops. Don't think much of it. Few days later, a few more pops. Then, again a few days later, pops and then now sound coming from the speakers. The radio is a stock radio and still has power, but no sound coming out. I know that the speakers arn't blown so I go to check the factory amp, and I can't find it. Someone told me it's behind the spare tire, but its not there. The only thing I see is a small box that looks like it's an anti-theft computer, but i'm not sure. Just wondering what to do or where to start. Please help. Thanks
aelandry is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-05-2005, 06:57   #2 (permalink)
Registered User
 
Freshmeat's Avatar
 
Join Date: Sep 2005
Location: Geismar, LA, USA
Age: 31
Posts: 833
Re: '93 Grand Marquis Audio Problem

That probably is your stock amplifier. They don't look anything like aftermarket- just a metal box with a crapload of wires hanging out all over the place.
__________________

My Garage
Freshmeat is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:40.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.