'93 Grand Marquis Electrical Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-31-2006, 15:39   #1 (permalink)
Registered User
 
Join Date: Aug 2006
Posts: 1
'93 Grand Marquis Electrical Problem

When I bought it the steering column was disassembled because the iginition switch needed to replaced..

I was driving into a parking lot, the car died as i was driving and then wouldn't start again.

I believe its an electrical problem for several reasons:

1. I believe there might of been exposed wires in the steering columns because i frequently heard the 'popping' sound when two wires touch that shouldn't when they spark.

2. My headunit and clock have no power, yet the cigar lighter does, and they're on the same fuse.

3. The lights in the car no longer shut off when all the doors are closed, they stay on until the battery dies.

Its not the fuel cut off switch/inertia switch, I checked but it wasn't triggered.

While I'm sure this could also just be a bad fuel pump, with all of the issues with the electrical, it doesn't seem likely. All the fuses were checked, nothing is blown.

Any help?
centic is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-31-2006, 17:58   #2 (permalink)
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 43
Posts: 1,486
Re: '93 Grand Marquis Electrical Problem

If the car is in good shape and I assume you bought it cheap with the problems described, I would take it to a shop to figure out the no start at least.

If the ignition is messed up, then the problem may be in the column causing all the problems you described.
Johnny Mullet is offline   Reply With Quote
Old 09-06-2006, 08:34   #3 (permalink)
Registered User
 
Freshmeat's Avatar
 
Join Date: Sep 2005
Location: Geismar, LA, USA
Age: 31
Posts: 833
Re: '93 Grand Marquis Electrical Problem

Something like this is a bit on the end of "bad idea" for someone just getting into things, but if you're determined...

take apart the column and look for loose/frayed wires. If you find any reconnect them where they belong. Pick up and Chilton's or Haynes manual if you don't have the cash to swing for a dealer manual (which aren't easy to come by) so you can follow the diagram involving the ignition, radio, and clock.

Good luck!
__________________

My Garage
Freshmeat is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 12:33.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.