97 Crown, Blows Fuse when gear to reverse - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-03-2007, 12:19   #1 (permalink)
Registered User
 
Join Date: Oct 2007
Posts: 3
97 Crown, Blows Fuse when gear to reverse

I have a strange problem...

When I put the gear shifter into reverse, it blows the fuse (which affects the lower brake lights, the turn signals, AC, etc).

If you put the car in Neutral, THEN start it, put it in Drive, the fuse is ok and the AC, turn signals, and brake lights work. It's going past the Reverse gear selection that blows it.

I isolated the reverse light bulbs by disconnecting them from the harness, and inspected the harness back to the fuse block. I can't disconnect the harness at the kickpanel due to the fact that the fuel cutoff switch is also in it and the car won't run with it disconnected...

Thinking about the Reverse circuit, as far as I know the only thing it does is power the Reverse lights, and turn off the rear view mirror anti glare feature...

Before I really dig in to the wiring, is there any obvious things to check, or is this a common thing with a common fix?

Thanks!
inamaze is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-06-2007, 18:19   #2 (permalink)
Registered User
 
Join Date: Oct 2007
Posts: 3
Re: 97 Crown, Blows Fuse when gear to reverse + Update

Made some progress on it.

Pulled the light harnesses, and all harness connections up to the front kick panel, so it's not in the bulbs, sockets, or wiring up to the driver's kick panel.

Pulled the next set of connectors going up to under the dash, then connectors to the light control unit, still no go.

Took the steering column apart and found a dangling wire (same color as goes to the reverse lights). Isolated it, but still no change.

Pulled the connector out of the turn signal switch box, and the fuse no longer blows... progress. Took it apart and found no faulty connections or contacts.

Tried to find another sensor along the shift linkage, and finally ended up considering the MLPS sensor may be at fault. They fail at the connector sometimes... hence the upgraded connector with new units (changed this on my Bronco).

I disconnected the shifter link which takes the MLPS out of the loop, and that was it...

So it's isolated (and my interior is compeltely apart...). I need to get under there and look at the connector and wiring. Hopefully that will pan out.
inamaze is offline   Reply With Quote
Old 10-06-2007, 19:17   #3 (permalink)
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,708
Re: 97 Crown, Blows Fuse when gear to reverse

I know it is alot of work, but it is the only way to find the problem. At least you're not paying someone else. Thanks for the update.
thefonz is offline   Reply With Quote
Old 10-07-2007, 21:49   #4 (permalink)
Registered User
 
Join Date: Oct 2007
Posts: 3
Re: 97 Crown, Blows Fuse when gear to reverse

Picked up the MLPS at Napa today ($65, cheaper than the dealer and cheaper than Baumann Controls which is excellent for this type of thing...). Installed it and I'm back in business, no more blown fuses.

I should have pulled the codes, I bet it would have shown up and possibly saved me about 3 hrs of time....
inamaze is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 05:00.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.