97 crown Vic Starting problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 09-18-09, 11:57 PM Thread Starter
Registered User
 
Join Date: Sep 2009
Location: Orem Utah
Age: 64
Posts: 4
97 crown Vic Starting problem

I thought it was the Ign switch but after replacing it the only problem solved was key in dinger stopped.(sounded off all the time till door was closed) Starter only makes a slight noise when shifter is moved with key in start position. (Same problem before installing new switch) So does anybody know where they hide the Neutral safety switch on this model.
crzydave is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-19-09, 12:33 AM
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 6,690
Re: 97 crown Vic Starting problem

On 1992 and later models, the neutral safety switch is incorporated into the Manual Lever Position or Transmission Range MLP/TR sensor.

jwko is offline  
post #3 of 6 (permalink) Old 09-19-09, 09:41 AM Thread Starter
Registered User
 
Join Date: Sep 2009
Location: Orem Utah
Age: 64
Posts: 4
Re: 97 crown Vic Starting problem

Info for the 97 is sketchy(one calls it an inhibitor and one says it is incorporated in the range selector one says it is a stand alone on the trans and one says it is on the selector column) and I don't want buy a manual (the manual I picked up at the library referred me to section 7B alas there was no section 7B) so I will just buy the part and match it up to it's location Thanks.
crzydave is offline  
post #4 of 6 (permalink) Old 09-19-09, 05:10 PM
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 6,690
Re: 97 crown Vic Starting problem

It should be in the range selector on the side of transmission.

The range selector is shown in the photo above.
jwko is offline  
post #5 of 6 (permalink) Old 09-20-09, 12:19 PM Thread Starter
Registered User
 
Join Date: Sep 2009
Location: Orem Utah
Age: 64
Posts: 4
Re: 97 crown Vic Starting problem

yes it was the range selector. The parts house's looked it up as the safety switch.Autozone $86 Checker $57 Pep boys $27 of course I choose the cheapest. After pulling the old part off I found another problem. The new part did not have the proper mounting spacers. Autozone's pic's looked just like the old one checkers had spacers so I built spacers and it mounted just fine. thanks for the Picture and Info it realy helped.
crzydave is offline  
post #6 of 6 (permalink) Old 09-20-09, 02:42 PM
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 6,690
Re: 97 crown Vic Starting problem

Glad you got if fixed.
jwko is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome