97 Grand Marquis electrical problem? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-05-2008, 17:05   #1 (permalink)
frank n texas
 
Join Date: May 2007
Location: Texas
Posts: 17
97 Grand Marquis electrical problem?

Hello all..Need some input here please...

Have 1997 Mercury Grand Marquis with 85,000 on the clock...car is factory original as far as electrical wiring...

Driving home last night I noticed dash cluster and radio cluster lights ever so lightly flickering...Not going on and off but flickering like on a scale of 1 to 10
the dimming or flickering would be like between 1 and a 2...

At the same time I noticed the red outlined battery icon was ever so slightly trying to light up on the dash...

I could not match the timing of the flickering dash cluster lights to increase or decrease in the rpms of the engine...

I had the headlights set on auto switch...

I could not tell from inside the car if the headlights were also flickering slightly.

All lights are working as are the turn signals, dome light and interior floor lights

Auto head lights are working just fine.They light, stay on while driving day or night and automatically turn off after I exit the car in a couple minutes...

I am a senior who lives alone and this is my only transportation and at this point I am afraid to drive the car anywhere for fear of it going dead..

Give me your best shots here please..

Thanks in advance

frank n texas
frank n texas is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-03-2008, 20:49   #2 (permalink)
Registered User
 
Join Date: Jun 2007
Posts: 10
Re: 97 Grand Marquis electrical problem?

Voltage regulator going bad? It might be in the alternator. I know that older cars had them seperate. My Chevys were built into the alternator.
Hope that helps. Could be as simple as a weak battery, but Im betting of the earlier
roughstock is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:52.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.