98 Crown Vic Problem. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-27-09, 04:02 PM Thread Starter
Registered User
 
Join Date: Jan 2009
Posts: 1
98 Crown Vic Problem.

Hi yeah..

My Vics been stumbling during drive, hesitation to go off stop. My brother's friend works at the Ford dealer and says that the cats are probably backed up and the easiest and cheapest way is just to cut them off. Another of his friends said its either that or the fuel filter.

Anyways the thing won't get past 30 and the check engine light is always on and blinks after a while of driving.

So should I pay 80 bucks to cut off the cats?

Justinje is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-29-09, 05:34 AM
Ozzy
 
Osmossis's Avatar
 
Join Date: Oct 2006
Location: Milton, Ontario
Age: 30
Posts: 53
Re: 98 Crown Vic Problem.

i would spend $10 bucks and replace the fuel filter first, i would hold off on cutting the cats off due to the cost of putting new ones on. up here we have emission testing i had to replace the cats the cheapest universal ones are around $140 and fords were $250 and you will need 4.

Pain Heals Chicks Dig Scars Glory However Brief Lasts Forever
Loud N Proud:
Osmossis is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome