99 Crown Vic issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-19-10, 11:55 PM Thread Starter
Registered User
Join Date: Mar 2010
Posts: 12
confused 99 Crown Vic issues

Hey, Im new here and Im trying to get pointed in the right direction...

I have a 99 CVPI, thats idling rough also sometimes when accelerating it bucks. I've given it a tune up, and the codes coming up are P1151 and another for the O2 sensor. Im completely stumped because the car has power and if Im accelerating and the stutter starts to happen if I press down on the pedal it will smooth out and pick up normal speed. It starts fine, and when in park the idle is normal...

To me it seems like maybe something fuel related or possible exhaust, I did have a cylinder 6 misfire before but once the plugs and everything were replaced I haven't got that code again...

Please if any ideas or a general direction someone can point me in would be greatly appreciated.
99CVPI is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-20-10, 09:39 AM
2002 F150 XLT
Bert's Avatar
Join Date: Nov 2008
Location: Oregon
Posts: 10,246
Re: 99 Crown Vic issues

P1151 usually doesn't cause driveability issues. Here's info on it. OBD Trouble Code: P1151 Lack of HO2S-21 Switch, Sensor Indicates Lean Try cleaning the MAF with MAF cleaner.
Welcome to the forums.

Bert is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome