99 CV P71 Turn Signal flasher problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-25-07, 02:04 PM Thread Starter
Houstonbound
 
hoosierp71's Avatar
 
Join Date: Aug 2005
Location: North Vernon, IN
Age: 28
Posts: 18
99 CV P71 Turn Signal flasher problems

Well I recently purchased some hyper white 3157's for my front turn signals and the passenger side signal works great, but the driver's side is a different story, the indicator on the dash flashes rapidly as to indicate a bad bulb, LED, or short.. but the bulb was fine, i tried another bulb same thing. The rear flasher works just fine except at a fast rate like the indicator. Could this be a short in the pigtail to the bulb? or something else, I dont have a DVOM to test things so please help me guys.


'99 Ford P71 - ~Big Red Drift Boat~
'88 Honda CRX
'88 Chevy S-10
'87 Toyota Corolla (RWD) Coupe

*Principal Hearne* "Do you know anything about digital photo editing?"
*Tony* "Enough to know why I'm here..."
hoosierp71 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-26-07, 02:22 AM
Registered User
 
Join Date: Sep 2006
Location: Burlington, Ontario
Posts: 105
Re: 99 CV P71 Turn Signal flasher problems

Well, if the old bulbs worked just fine, and it was immediately after the swap that things stopped working, I wouldn't suspect anything too major. Check to make sure the bulb is in correctly, and also check to make sure it's seated properly so it's hitting the contacts.

If the old bulbs weren't working, then I'd suggest you could have a short somewere, or more likely, a bad ground. No meter? Do yourself a favour & pick up one - the digital meters aren't as costly as they once were. You don't need one too complex, just one that will do the trick in instances like this. They can really cut down on diagnostic time...
Lambykin is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome