99 p71 turn signal intermittent rapid flashing, followed by failure - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-14-07, 03:22 PM Thread Starter
Registered User
 
Join Date: May 2007
Posts: 1
99 p71 turn signal intermittent rapid flashing, followed by failure

new to the forum, my first post, hi to everyone.

my 99 cvpi was exhibiting an intermittent symptom with it's turn signal. from time to time, seemingly randomly, my turn signals would flash at a faster than normal rate. recently they stopped working all together. i've heard of other people having the rapid flashing issue before.

my car is completely stock, there have never been any other electrical issues with the car at all, it has 160k and has been mechanically sound for the 3 years i've owned it.

thanks guys!

falseaddress is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome