A/C Issue - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-12-08, 08:46 AM Thread Starter
Registered User
 
Join Date: Apr 2005
Posts: 18
A/C Issue

I have a 2003 Grand Marquis LS with climate control. When i start the car and turn the a/c on it blows warm air until the temperature gage gets to normal reading and then the a/c kicks in. I usually have the inside temp set at 65 degrees at start up to get the a/c going as fast as possible and then I set it higher when the a/c kicks in. This continues after the car sits and then I go through the entire procedure again. Anybody dealt with this issue or know of what it could be?

Any help is greatly appreciated.
tecumseh_bill is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-12-08, 09:09 AM
Registered User
 
phantom_smack's Avatar
 
Join Date: Jul 2008
Posts: 19
Re: A/C Issue

What happens in the manual ac mode?
phantom_smack is offline  
post #3 of 4 (permalink) Old 08-12-08, 03:04 PM Thread Starter
Registered User
 
Join Date: Apr 2005
Posts: 18
Re: A/C Issue

Same thing in manual. Also checked refrigerant. It is OK
tecumseh_bill is offline  
post #4 of 4 (permalink) Old 08-27-08, 03:31 PM Thread Starter
Registered User
 
Join Date: Apr 2005
Posts: 18
Re: A/C Issue

Problem solved. Faulty relay - $40.00
tecumseh_bill is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome