A/C not working. Help Please! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-29-09, 09:13 AM Thread Starter
Registered User
 
Join Date: Jul 2009
Posts: 4
A/C not working. Help Please!

Hi, new guy here needing some help. I have a 95 crown vic and the a/c started acting up going off and on for about the last week, but now does not word at all. here is what I have done so far. I checked the fuse,jumped the pressure switches, changed the relay, and put a new clutch on. None of it has worked. now what I realize is the clutch is not getting power. it does click on if I jump it to the battery, but I can't figure out why the wire isn't getting power even when I jump the pressure switch. Any ideas would be greatly appreciated. Thanks
stevenj is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-29-09, 09:43 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,281
Re: A/C not working. Help Please!

Here's the diagram for your (manual) A/C.
Attached Images
File Type: jpg AC.jpg (93.2 KB, 7 views)
Bert is offline  
post #3 of 3 (permalink) Old 07-29-09, 09:56 AM Thread Starter
Registered User
 
Join Date: Jul 2009
Posts: 4
Re: A/C not working. Help Please!

Thanks for the diagram
stevenj is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome