The car - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-15-04, 03:31 PM Thread Starter
That guy
 
BlueSteel's Avatar
 
Join Date: Jul 2004
Location: Belleville michigan
Age: 29
Posts: 389
frown The car

I found the heating problem with my 1987 LTD Crown Victoria LX. The water pump has rusted away. I took off the small tube that connects the intake maifold to the water pump. I have this cable camera. I looked inside and the fans are gone, only nubs are there. This car has been sitting in a backyard for 2 years with no antifreeze and wrong 1 core radiator. I pulled a water pump off another junker crown I have over here. Its a nice aluminum one that measures up. Next week end I'll put the water pump on. I kept wondering what that scrathing sound was every time I hit the throttle hard. Thought the emission pump was going. I'm just going to drive my hurst untill I get to fix the 87 crown. I'll send pic when I figure out how.


Blue Anodized Steel
The Apocalypse is coming, are you ready?

BlueSteel is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome