COMPASS not working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-21-2011, 08:34   #1 (permalink)
Registered User
 
Join Date: Sep 2010
Posts: 3
COMPASS not working

Hi all..

My 2003 Crown Vic LX compass in overhead console isn't working, meaning it won't light up. I am currently going to check the fuses. According to manual, that fuse controls other areas and everything else on car works. So, I am not optimistic about the fuse being the problem. Any other places to start???
Many thanks!!
aughtsix is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-21-2011, 11:56   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,807
Re: COMPASS not working

If the fuse is okay, check for power in the violet/orange wire. It should 10v or more with the key on. If it's okay check the resistance from the pink/orange wire to ground with the key off. It should be 5ohms or less. If they're both okay, you need a new compass module.
__________________
Bert
Bert is offline   Reply With Quote
Old 05-21-2011, 12:47   #3 (permalink)
Registered User
 
Join Date: Apr 2011
Posts: 22
Re: COMPASS not working

If you tap on it does it light? This is a common problem on Marauders since they all have overhead consoles with a compass. If you tap on it and it lights it is a bad solder joint. When I removed mine a resistor fell out of it after I opened it up. I re-soldered it back in and it has been working fine for about a year now.
glenn-ho is offline   Reply With Quote
Old 05-22-2011, 06:22   #4 (permalink)
Registered User
 
Join Date: Sep 2010
Posts: 3
Re: COMPASS not working

Thanks Bert and Glenn. It is repaired!!
aughtsix is offline   Reply With Quote
Old 05-23-2011, 10:43   #5 (permalink)
Registered User
 
Join Date: Apr 2011
Posts: 22
Re: COMPASS not working

How did you repair it?
glenn-ho is offline   Reply With Quote
Old 05-25-2011, 11:38   #6 (permalink)
Registered User
 
Join Date: Sep 2010
Posts: 3
Re: COMPASS not working

Pulled console down. Pulled display apart to get to circuit board. Couldn't find anything loose. Plugged board back in to wiring. Started to wiggle stuff around to see what happened. Pushed the mode button (on circuit board) a couple of times and display came on. Wiggled around some more. Turned key off and on several times. Display always came on. Been working since last post. Probably not really "repaired" We will see. Thanks for your help.
aughtsix is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 14:27.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.