Dome light not working when door open - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-15-11, 06:05 AM Thread Starter
Junior Herb
 
ToxicAdam's Avatar
 
Join Date: Oct 2009
Posts: 174
Question Dome light not working when door open

It started with the front dome.. two weeks later the back seat dome lights stop.

What's happening?

'99 grand marquis
ToxicAdam is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-15-11, 06:41 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 13,942
Re: Dome light not working when door open

Probably the switches at lock assembly , this shows you set up . May just need cleaning / WD40 .

I have a 1999 Mercury Grand Marquis which is fully loaded. - JustAnswer
R.S.LOGAN is offline  
post #3 of 3 (permalink) Old 12-15-11, 11:45 PM Thread Starter
Junior Herb
 
ToxicAdam's Avatar
 
Join Date: Oct 2009
Posts: 174
Re: Dome light not working when door open

tHANKS, I'll check this out
ToxicAdam is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome