Electrical cutting in and out. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-19-2013, 06:20   #1 (permalink)
Registered User
 
Join Date: Feb 2012
Posts: 5
Electrical cutting in and out.

'93 Towncar, 187k. Came to a stop today and the radio and climate control cut out. Came back on then did so again while driving afew times in a row, After awhile it killed the motor for a split second and came back on. When driving if i tap the brakes or hit the blinker the climate control shuts off and starts again, Check engine light and ABS light come on. The a service air suspension light flickered. Finally i got home, came to a stop and the whole thing died.

Cars getting old but thats no excuse, Where should i start to look? Every connection in the engine compartment is as it should be. Anything common with these panthers?
tjb1984 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-19-2013, 08:22   #2 (permalink)
Moderators
 
Join Date: Jul 2011
Posts: 548
Re: Electrical cutting in and out.

Getting old is not an excuse, but it is a very good reason, as cars tend to wear out at around 20 years. At that point they begin require extra attention and maintenance.

This is obviously an electrical problem. Start with you battery connections. Are they clean and making good contact? From there, start checking wiring for intermittent shorts and corroded or loose grounds. The air pump hot lead tends to chafe near the left front frame near the pump.
Bajarider is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:38.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.