Electrical problems, 03 LS Crown Vic - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-16-08, 01:09 PM Thread Starter
Registered User
 
Join Date: Jul 2008
Posts: 1
confused Electrical problems, 03 LS Grand Marq.

Seven months ago I noticed that the headlights would dim and dash interior lights would flicker. The climate control fan would change speed too. The driver's side left power window was intermittent.
I took it to the local Ford dealer. They put in a new alternator and fixed the window problem.
In a couple days it started the same stuff. At the dealership they put in a new alternator and after spending a lots of time trying to locate where a short could be, they wrapped the harness.
Over the next 3 months it went through 2 more alternators.
All was well for the last 10 weeks but now I am starting to suspect. The alternator again... dash lights flicker.
Oh, and when all of this began the first abnormality I saw was that the indicaters were blinking twice as fast as the normally do. They have not reverted to blinking at the normal rate since this all began. I can get them to slow there rate of blink by loading up the e- sytem (rear defrost ,a/c and lights).
How do I find a place that can diagnos this gremlin that keeps chewing through alternators?
fnansen is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-17-08, 05:31 PM
Registered User
 
Join Date: Jul 2003
Location: texas
Age: 55
Posts: 97
Re: Electrical problems, 03 LS Crown Vic

I guess my previous post didnt take. quickly here you need to unplug the lcm or light control module as its called. it is located under the dash between the cig tray and steering wheel, more closer to the cig tray. It has about 3 harnesses. Take it out, (about 3 screws) open the box and make sure there is no corrosion inside of it. This module controls all the lighting, blinking, dimming for all the lights. I had corrosion in mine. I also had a problem with my headlights and all going on and off flickering. I removed the front dash - instrument panel, and reconnected all the harnesses. after that my headlights never flickered again. You have to open the doors, pull out the plastic molding on the front panel and behind that you will find screws to loosen the front panel. I think just disconnecting and reconnecting all the harnesses took care of the intermittent problem. good luck. art
mercdriver is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome