Emissions problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-07-2006, 18:47   #1 (permalink)
Registered User
 
Join Date: Aug 2006
Posts: 5
Emissions problems

I have a 1992 MGM. I took it in for emissions test saturday, and it failed. I found a vaccuum leak in the PCV line. Fixed that, and passed, but only by 1/10 of a point. High HC. After the e-check, i cleared the computer, and drove it until the check engine light came back on. The codes i got were 542, (Fuel pump circuit open), and 332, (Insufficient EGR flow). I think i can probably figure out the 332, but the 542 is kinda bothering me. The car runs fine most of the time, but sometimes it wants to stall when idling. Any help on any of these 2 issues would be appreciated.
__________________
RK4332 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-08-2006, 08:43   #2 (permalink)
Registered User
 
Join Date: Dec 2003
Posts: 160
Re: Emissions problems

well if the car wants to stall while idleing than that is your IAC vavle. As for the fuel pump not sure.
amo4387622 is offline   Reply With Quote
Old 09-09-2006, 20:27   #3 (permalink)
HO conversion guru
 
Join Date: Aug 2005
Location: Georgia
Posts: 83
Re: Emissions problems

check your fuel pressure, the pump may be weak and the verge of failure.
88grandmarq is offline   Reply With Quote
Old 09-09-2006, 20:29   #4 (permalink)
Registered User
 
Join Date: Aug 2006
Posts: 5
Re: Emissions problems

Hmmmmm, My fuel pump is kinda loud. I'll check that.
__________________
RK4332 is offline   Reply With Quote
Old 09-09-2006, 20:47   #5 (permalink)
HO conversion guru
 
Join Date: Aug 2005
Location: Georgia
Posts: 83
Re: Emissions problems

Clean the hot wire on your MAF sensor, that should help.

on the EGR, most likely the EGR channels in the lower intake are gunked up, also check the EGR supply tube, those cars are notorious for breaking the tube.
88grandmarq is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:08.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.