Firing order - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-29-05, 08:05 PM Thread Starter
Registered User
 
Join Date: Sep 2005
Location: Topeka
Posts: 10
Firing order

Could someone please give me alittle information? Ineed the firing order for a 1988 5.0 HO. I dont know which one is right. I took the the EFI MAF off and put a edelbrock rpm intake along with a 600 holly. The chiltons I was using disappeared. If I remeber right, there were two different ones, One was for a HO the other was for a straight 302. There's been a few laugh's becouse my moter and tranny and rear end came out of a lincoln Mark VII, I hope Ill be able to shut there mouths for them. I would appreciate someone's help.


Bob Lewis


Bob43
Bob Lewis is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-29-05, 09:32 PM
That guy
 
BlueSteel's Avatar
 
Join Date: Jul 2004
Location: Belleville michigan
Age: 29
Posts: 389
Re: Firing order

I hope this helps. http://www.autozone.com/servlet/UiBr...7EFIRING+ORDER

Blue Anodized Steel
The Apocalypse is coming, are you ready?

BlueSteel is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome