Front-end "clunk"... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-24-07, 07:01 PM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 41
Front-end "clunk"...

For those of you who may have a similar problem...I think I finally fixed my front-end clunk by replacing the upper ball joints. I replaced the tie-rods as well but most of the "clunkage" seemed to be caused by the ball joints. This site has some good info on how to do it yourself for those of you so inclined...

Autoclinix.com - Ford Crown Victoria / Mercury Grand Marquis Upper Ball Joint Replacement Instructions

sheebeehuh is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome