funny problem i had - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-18-07, 12:47 PM Thread Starter
Registered User
 
Join Date: Oct 2006
Location: Michigan
Posts: 34
funny problem i had

Hi. First some backstory:

I had a miss (with cel) caused by coolant leaking into #1 plug cavity. I changed the intake manifold and did plugs at same time. Car ran fine for a couple of months but now I have a small intermittent miss normally when warm at any throttle position.

I checked the plug torque, coil boots, connections, connections on all my sensors, etc. I also decided to clean the IAC and MAF just to see if this made any difference. While removing the MAF I noticed that the airbox lid just popped right off in my hand with no real force applied. It turns out that the box is all soft and warped and the lid will not make a good seal so I was sucking unfiltered air down the TB. Nice. I've got a new box coming to me and hopefully after a nice TB cleaning I'll be good to go. Has anybody ever heard of such a thing?

thehamstack is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-19-07, 06:25 AM
Registered User
 
Join Date: Dec 2006
Posts: 24
Re: funny problem i had

The Aircleaner/filter should be in front of the MAF so even if you suck in a bit of unfiltered air it shouldn't affect the way it runs since the air is still metered,
now if unmetered air is entering the TB then it would run a bit rough.
Did you check for vacuum leaks?
Tom1222 is offline  
post #3 of 3 (permalink) Old 01-21-07, 04:00 PM Thread Starter
Registered User
 
Join Date: Oct 2006
Location: Michigan
Posts: 34
Re: funny problem i had

When I get a good filter on it I plan to check for vac leaks. I did just after I changed the intake and found none, but things change, so that's my next step
thehamstack is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome