Heater only works on Face Melt setting - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-21-10, 06:46 PM Thread Starter
Registered User
 
Join Date: Mar 2010
Posts: 15
Heater only works on Face Melt setting

My 03 p71's blower only works on high, the resistor pack is toast I'm assuming as I enumerated everything else. I'm going to replace it but I just want to know where its at so I dont have to rip the car apart.
Thanks!

bowser22 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-21-10, 07:24 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,298
Re: Heater only works on Face Melt setting

It's on the heater box right behind the passenger side valve cover. Some have a plastic cover over the plug. You'll probably need a connector plug too.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome