HELP with Hard Steering - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-15-2010, 10:47   #1 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 2
HELP with Hard Steering

Okay im new to this forum an im a tech but this ones got me really stumped so i need some help. I have an 05 crown vick that use to steer like it had somethen wedged in the rack and pinion. I verified this by disconnecting the outer tierod ends and turning the car on and trying to steer it. So in went a new rack hooked everything back up then the pump wasn't pumping. So i replaced the power steering pump now after doing all this i have the problem of it now steering as if there is no power steering and im stuck as to wat could cause this. Any help would be greatly appreciated.

P.S.
The car has the EVO system on the rack.
crazytech187 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-19-2010, 19:41   #2 (permalink)
Registered User
 
Join Date: Jul 2010
Posts: 48
Re: HELP with Hard Steering

have you checked for power to that solenoid on the rack and what's the brand of rack you installed?
no_common_sens is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 19:13.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.