HELP! my crown vic is losing coolant... sometimes? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-21-2007, 14:21   #1 (permalink)
Registered User
 
Join Date: Feb 2007
Posts: 7
HELP! my crown vic is losing coolant... sometimes?

I have a 1993 crown victoria LX with 160k miles. I've owned the car for the last year & it has been a pretty good car. I've had to replace minor parts only. The other day I was driving downtown in traffic & when I stopped I heard a spray. I figured it was a hose so I went up front & popped the cap to save any coolant I had left & I started looking around for the source of the leak. All I could see was lots of coolant draining down from around the bell housing, I can not find the leak. I limped back to my house dumping coolant all the way & parked it on the street until today (3 days later). I went out & filled it up with water & screwed the cap on loosely to move it for street cleaning day & to my suprise there is no leak! The heater makes a bubbling sound when it's on, but it goes away when I turn it off. What do you guys think this could be? My heater core? Why is it no longer leaking?
shanescrownvic is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-24-2007, 23:46   #2 (permalink)
Fire/Rescue
 
rescue76's Avatar
 
Join Date: May 2007
Location: Corbin Ky
Age: 32
Posts: 29
Re: HELP! my crown vic is losing coolant... sometimes?

Lots of fluid around the bell housing....bubbling from heater being on....Water Pump going bad?
rescue76 is offline   Reply With Quote
Old 05-27-2007, 17:31   #3 (permalink)
Registered User
 
Join Date: Feb 2007
Posts: 7
Re: HELP! my crown vic is losing coolant... sometimes?

i dont know, is it? I didn't think it was the water pump since when i fill the coolant resivior back up it sucks it right down into the motor quickly & the car does not overheat. It just looses the coolant, even when it's just sitting there. any suggestions? the car is parked out on the st & i can't leave it there for long.
shanescrownvic is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:31.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.