HELP!PLEASE! My transmission is screwed! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-20-2010, 16:59   #1 (permalink)
Stankin Lankin
 
Join Date: Oct 2009
Location: Illinois
Posts: 32
Exclamation HELP!PLEASE! My transmission is screwed!

Hello all. Its been a while but I could really use the help. Today started bad and went to hell. First off, my tire blew up on my 92 TC. All the belts broke straight across the tire. Second, I was driving and my car started smoking. I stopped on the side of the road bc I thought that my spare tire blew also. Boy was I dead wrong. I got out only to find transmission fluid leaking all over the place. I thought it was leaking from the bell housing. I got it towed home and got it in the air. I took a second look and seen that the fluid was coming from the fly wheel housing. Now, I don't know that much about transmissions and frankly, I'm a little afraid to work on it. I just want to pick your minds to see if anyone would know what the problem would be. Even if I just start the car, fluid comes pouring out. I would greatly appreciate the advice
agon3279 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-20-2010, 18:21   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,658
Re: HELP!PLEASE! My transmission is screwed!

The 92 Town Car had a plug in the convertor to drain the fluid. There's a 2" rubber plug at the bottom of the housing. Pull the plug and turn the convertor to see if the plug might have been put in loose sometime and fallen out. If not, the front seal may have blown and the transmission will need to be removed for repair.
__________________
Bert
Bert is offline   Reply With Quote
Old 02-20-2010, 18:29   #3 (permalink)
Stankin Lankin
 
Join Date: Oct 2009
Location: Illinois
Posts: 32
Re: HELP!PLEASE! My transmission is screwed!

thats the thing. There was never any work done to the transmission. I bought the car with 136000 on it and now has 141000. When I first initially looked at it, there was fluid coming out of the rubber plug. After I stopped, I shut the car off, started it again, and there was fluid coming out of the plug with the motor running but in park. But there was also fluid coming out of the flywheel housing. So could it be both, and how much work is involved in taking out the trans and replacing the seal or torque converter?
agon3279 is offline   Reply With Quote
Old 02-20-2010, 19:21   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,658
Re: HELP!PLEASE! My transmission is screwed!

Some time before you bought it the trans. may have been serviced and the plug left loose. Pull that rubber plug and see if the plug is still in the convertor. You can also look in there to see what direction the fluid is coming from if it's not the plug.
__________________
Bert
Bert is offline   Reply With Quote
Old 02-20-2010, 19:27   #5 (permalink)
Stankin Lankin
 
Join Date: Oct 2009
Location: Illinois
Posts: 32
Re: HELP!PLEASE! My transmission is screwed!

ok. I will try it. I will let you know what happened. Thanks for the help. I really appreciate it.
agon3279 is offline   Reply With Quote
Old 02-28-2010, 14:02   #6 (permalink)
Stankin Lankin
 
Join Date: Oct 2009
Location: Illinois
Posts: 32
Re: HELP!PLEASE! My transmission is screwed!

UPDATE:
Ok. I did not have the time to play around with the car so I had it towed to the shop. I thought it was going to be really bad but it turned out that the bearing on the front pump spun. I think it was from the last big snow here in chicago. I got stuck in the snow in my parking lot and tried to get out for an hour. But it is repaired now but it wont be ready till sometime this week bc the fuel lines were really rusted.
agon3279 is offline   Reply With Quote
Old 02-28-2010, 15:40   #7 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,658
Re: HELP!PLEASE! My transmission is screwed!

Thanks for the update.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:39.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.