Lack of Power - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-19-2006, 17:15   #1 (permalink)
Registered User
 
Join Date: Jul 2006
Location: Czech Republic
Age: 30
Posts: 2
Lack of Power

I've got 1989 Mercury Colony Park for three weeks, and i have got problem with lack of power - I have to put the gas pedal almost on the floor to make the car move. Also on higway, when going up the hill, at 75MPH the car begin to slow down very quickly. Could the problem be only overheating? I have found that the fan clutch is bad and have ordered a new one. Oil, water, sparks, cables,... looks to be OK. Thanks for any reaction.
Lord Iffy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-19-2006, 20:27   #2 (permalink)
Crownvic
 
CrownVic's Avatar
 
Join Date: Aug 2005
Location: Canada
Age: 33
Posts: 105
Re: Lack of Power

What kind of fuel system? Carburated? EFI? Or *gasp* variable venturi??
CrownVic is offline   Reply With Quote
Old 07-20-2006, 07:47   #3 (permalink)
Registered User
 
Join Date: Jul 2006
Location: Czech Republic
Age: 30
Posts: 2
Re: Lack of Power

it is EFI, the same engine which is in Lincoln TownCar to 1990
Lord Iffy is offline   Reply With Quote
Old 07-20-2006, 18:41   #4 (permalink)
Registered User
 
Join Date: Dec 2003
Posts: 160
Re: Lack of Power

Have you checked the TPS voltage? And what have you done to the car? I would think about replacing the fuel filter.
amo4387622 is offline   Reply With Quote
Old 07-21-2006, 05:42   #5 (permalink)
HO conversion guru
 
Join Date: Aug 2005
Location: Georgia
Posts: 83
Re: Lack of Power

I seriously doubt you have an overheating problem. check some of the basics, is the air filter clean? is the air intake clear (no debris clogging the intake hose/pipe). make sure there is not an exhaust restriction, some times the cat converters will come apart which will cause a restriction as well as the debris from the converter cloggs the muffler(s). most exhaust shops can check the exhaust for restriction. make sure the motor has an ample fuel supply, replace the fuel filter, check for kinks/restrictions in the fuel supply line, put a fuel pressure gauge on the motor, make sure you have correct fuel pressure. if its low, you may have a failing fuel pump.

also check the base igition timing, factory spec is 10 degress BTDC with spout connector pulled.
88grandmarq is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:56.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.