Lamp problem on 89 Mercury Grand Marquis, HELP!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-29-2010, 11:48   #1 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 6
Lamp problem on 89 Mercury Grand Marquis, HELP!!

Just found your forum, didn't know there was one for the Big Fords! Glad i found you!

Can you help me please??

I have a headlight problem with an 89 Mercury Grand Marquis, The dip beam keeps flickering and going on and off? Does it have a relay that could be burning out? All other lights work fine even the main beam. When the dip beam goes off the main beam is still live and working (IE the mains click on and off on the dip switch) it's kinda like the dip beam bulbs are blown, but obviously they are ok! Could it be a headlight switch? If it is how come the mains still switch on/off with the lamps in on position (switch pulled out) but when the lights are not lit (IE when its pi**ing me around?) any help guys?

Cheers guys
TheBigChevyGuy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-29-2010, 11:56   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,758
Re: Lamp problem on 89 Mercury Grand Marquis, HELP!!

When the light go out is it blinking sort of rhythmically? When the lows go off, do the highs still work and stay on?
__________________
Bert
Bert is offline   Reply With Quote
Old 01-30-2010, 02:52   #3 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 6
Re: Lamp problem on 89 Mercury Grand Marquis, HELP!!

Quote:
Originally Posted by rtg143 View Post
When the light go out is it blinking sort of rhythmically? When the lows go off, do the highs still work and stay on?
The lights just flicker off and back on then sometimes dont come back on untill the car has rested for a while? When the low beam plays up the mains still work, i had the same problem on a 91 gran mark only that one affected the mains aswel? I'm a mechanic by trade and this problem is killing me (it's my own car, daily driver)

Thanks
TheBigChevyGuy is offline   Reply With Quote
Old 01-30-2010, 02:57   #4 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 6
Re: Lamp problem on 89 Mercury Grand Marquis, HELP!!

Just to add it has auto lamps aswell, even when thats turned on the low beam goes off but alll the others work just fine?
TheBigChevyGuy is offline   Reply With Quote
Old 01-30-2010, 07:58   #5 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,758
Re: Lamp problem on 89 Mercury Grand Marquis, HELP!!

The dimmer switch probably has a problem with the internal contacts or the connection to it.
__________________
Bert
Bert is offline   Reply With Quote
Old 01-30-2010, 09:15   #6 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 6
Re: Lamp problem on 89 Mercury Grand Marquis, HELP!!

In the manual is states there is a integral circuit breaker in the lamp switch? Is this right? If so i think its this thats playing me up. Wondered if i could solder a external fuse onto it... Hummm

I pulled out the switch and it's been replaced not long ago by the look of it, plug connector is all ok not burnt or melted.
__________________
1980 Chevy Caprice Classic
1983 Chevy Caprice Station Wagon
1989 Mercury Grand Marquis LS
TheBigChevyGuy is offline   Reply With Quote
Old 01-30-2010, 13:14   #7 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,758
Re: Lamp problem on 89 Mercury Grand Marquis, HELP!!

There is a circuit breaker in the switch but it would shut the High beams off too.
__________________
Bert
Bert is offline   Reply With Quote
Old 02-01-2010, 11:55   #8 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 6
Re: Lamp problem on 89 Mercury Grand Marquis, HELP!!

Problem sorted, turned out to be the headlamp dip switch on the steering colum. The Contacts in the switch were burnt up an the connection plug had melted on the switchable beam circuit terminal! Replaced the dip switch and the terminals now it's working! Cheers for the help, otherwise i would have been chasing the usual lamp switch.
__________________
1980 Chevy Caprice Classic
1983 Chevy Caprice Station Wagon
1989 Mercury Grand Marquis LS
TheBigChevyGuy is offline   Reply With Quote
Old 02-01-2010, 13:54   #9 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,758
Re: Lamp problem on 89 Mercury Grand Marquis, HELP!!

Glad you got it fixed. Thanks for letting us know.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:18.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.