Lock doesn't work - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-09-10, 06:46 AM Thread Starter
Registered User
 
Join Date: Jan 2009
Posts: 12
Lock doesn't work

I have a 99 Grand marquis, and when you try to unlock the door from the outside it doesn't unlock the door. I have to go to the passangers side unlock it, crawl through, and open my drivers side door. What would this be?

Is this common?

hornedfrog1985 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-09-10, 08:23 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,326
Re: Lock doesn't work

If the key turns and doesn't unlock it, the linkage probably broke or fell off inside the door. Doesn't the power lock work it?from the passengers side?

Bert
Bert is offline  
post #3 of 4 (permalink) Old 01-09-10, 08:11 PM Thread Starter
Registered User
 
Join Date: Jan 2009
Posts: 12
Re: Lock doesn't work

Nope, power locks don't work. I opened the door panel the other day, and its like the linkage is loose or something. I'm not even sure what I'm messing with because I can't see. I bought a new actuator on ebay a LONNNNNG time ago, but now I don't know if thats what it is. Too cold to really play with anything right now either.
hornedfrog1985 is offline  
post #4 of 4 (permalink) Old 01-09-10, 08:52 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,326
Re: Lock doesn't work

The actuator won't keep it from opening with the key. The linkage must have fallen off from the outside key cylinder. If the key turns the lock button, the clip might have come off from the handle part. Here's a picture of the clip. It's colored yellow and located on the latch. The actuator might also be defective. That's below the latch.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome