Need answers bout my 88 Crown Vic - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-28-2008, 15:08   #1 (permalink)
Dreadhead
 
dreadhead88's Avatar
 
Join Date: Jul 2008
Location: Dillon County, SC
Posts: 3
Need answers bout my 88 Crown Vic

I have a 88 crown vic ltd with a stock efi 302. i put a new water pump and thermostat on it but it still runs hot. im thinking i have cracked heads can anyone confirm this for me.

o and out of curiosity would any motor from the 385 series fit in my crown vic
dreadhead88 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-28-2008, 17:38   #2 (permalink)
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 5,931
Re: Need answers bout my 88 Crown Vic

Make sure the radiator is not clogged both internally and externally. Also check fan clutch
jwko is offline   Reply With Quote
Old 07-28-2008, 18:17   #3 (permalink)
Dreadhead
 
dreadhead88's Avatar
 
Join Date: Jul 2008
Location: Dillon County, SC
Posts: 3
Re: Need answers bout my 88 Crown Vic

i checked the radiator it good. i was thinkn the fan clutch but when you take the cap off the radiator while its running the water dont cycle it just sits there untill it starts getting hot and boils over
dreadhead88 is offline   Reply With Quote
Old 07-29-2008, 06:56   #4 (permalink)
Dreadhead
 
dreadhead88's Avatar
 
Join Date: Jul 2008
Location: Dillon County, SC
Posts: 3
Re: Need answers bout my 88 Crown Vic

still lookn for answer about the a motor for the 385 series (decided on a 460)
__________________
Could have got a chevy but i rather ride F.O.R.D
dreadhead88 is offline   Reply With Quote
Old 11-24-2008, 13:58   #5 (permalink)
89 LTD Crown Victoria LX
 
89CROWNVIC's Avatar
 
Join Date: Sep 2008
Location: Kansas City
Posts: 1
Re: Need answers bout my 88 Crown Vic

I ahd the same problem, replaced thermostat with new one, and turned out the new one was faulty. Also, common mistake, putting in backwards. I wopuld say that basically your thermo isnt opening, or maybe you got the wrong temp thermo, like actually needed a 165 but was sold a 185. If not thermo after testing or swappping out, you have a clog somewhere. Do you have coolant in your oil? Is it running out under the car? can you see coolant burning with the exhaust?
Additionallly, the book for the car such as Haynes is worth the cash, i got one for my crown vic. the library also has them in stock. free mechanical and technical info.
__________________
Dreams of a 'sic' Crown Vic!
89CROWNVIC is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 15:22.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.