Need help with o2 sensor replacement... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-06-10, 10:44 AM Thread Starter
Registered User
 
Join Date: Mar 2010
Posts: 12
Need help with o2 sensor replacement...

Im getting a p1151 lack of upstream heated oxygen sensor bank 2 sensor 1, I would like to possible replace it myself if its a relatively easy job. Where exactly is this specific sensor located and how do I replace it? I'd love to be able to do it my self and save a few dollars if possible.

99CVPI is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-06-10, 04:18 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,316
Re: Need help with o2 sensor replacement...

It's in the exhaust pipe just below the flange connection. If you could pus the gas pedal through the floor, you'd hit it.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome