Oil cap off all week, CEL on for good - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-03-11, 10:12 AM Thread Starter
Real radios use tubes
 
Join Date: Apr 2011
Posts: 1
Oil cap off all week, CEL on for good

For my first post, a real dumb move bears fruit:

Any chance leaving the oil-filler cap off for a few hundred miles will cause the CE light to come on? I put the cap back on once the light came on, and have driven another week, but it's still coming on. My car is a '96 Grand Marquis with the 4.6L. Any ideas?

WonderBar Tech is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-03-11, 11:18 AM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: Oil cap off all week, CEL on for good

Take it to Autozone or Addvance, etc. and have the codes read and cleared and see if it comes back on. Let us know what codes you get.
thefonz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome