oil pressure gauge - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-27-03, 07:36 AM Thread Starter
Registered User
Join Date: Jul 2003
Location: southeast
Age: 53
Posts: 6
oil pressure gauge

my problem almost seems electrical but ill post the question anyway.swapped 4.6s from a 94 cv,the first motors bearings were shot, so we used a 4.6 from a grand marquis. motor runs fine but after warm up the oil gauge drops to nothing but when i accelerate it goes to normal. but when the needle moves its jerky,mainly when i cut the a/c on. no rattling or nocking from the motor(except for a sticking lifter)replaced the pressure sensor on the filter housing but cant really seem to chase this one down. any one have a clue. oil screen is clean and the pump works good we checked it when we had the motor on the stand.
boondocksaint is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure sender units uteman General Tech 9 05-07-05 04:21 AM
EF-XR6 Oil pressure Gauge Probs buster100 General Tech 5 04-27-03 08:19 PM
oil pressure loss bigblockcoupe Ford Mustang Forum 2 09-10-02 11:09 AM
broken oil pressure gauge on ef ghia? trev General Tech 1 09-06-02 08:03 AM
Regular Oil Pressure Gauge Position Styles General Tech 13 08-05-02 03:46 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome