Parking brake indicator - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 Forum for discussion of the Ford Crown Victoria, Mercury Marauder, Mercury Grand Marquis and P71.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 01-26-10, 08:43 AM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 7
Parking brake indicator

Trying to get a car ready for the vicious maryland state inspection and the parking brake indicator won't work when parking brake is applied. I first thought it was the parking brake switch but when the key is turned on at first and the system does a bulb check, all lights come on EXCEPT the brake light. So my next thought was "oh the bulb is burnt out" so i took the gauge cluster out and checked the bulb. Bulb is good. Has anyone else run across this problem? Why won't this damned light ever light up! lol

ElliottsAuto is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 01-26-10, 08:58 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,298
Re: Parking brake indicator

What year is it? Crown Vic?

Bert
Bert is offline  
post #3 of 11 (permalink) Old 01-26-10, 09:08 AM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 7
Re: Parking brake indicator

oh sorry forgot to put that info lol. its a 94 Grand Marquis
ElliottsAuto is offline  
post #4 of 11 (permalink) Old 01-26-10, 09:18 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,298
Re: Parking brake indicator

It goes through the DRL if that has it. Here's the diagram.[IMG][/IMG]

Bert
Bert is offline  
post #5 of 11 (permalink) Old 01-26-10, 09:22 AM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 7
Re: Parking brake indicator

ok thanks man i'll look into that and see if it has DRL or not and if so i'll see if its working
ElliottsAuto is offline  
post #6 of 11 (permalink) Old 01-26-10, 09:47 AM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 7
Re: Parking brake indicator

no DRL. so i'm guessing test fluid level sensor? lol. cuz it looks like it would run thru the level sensor when it would do a bulb check. which would explain that, but looks like it should still light when the parking brake is applied even if the fluid level sensor were defective.
ElliottsAuto is offline  
post #7 of 11 (permalink) Old 01-26-10, 10:20 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,298
Re: Parking brake indicator

Either one grounds the light and turns it on. Push the float down in the master cyl. with something and see if the light comes on. That will tell you if the bulb area is okay.

Bert
Bert is offline  
post #8 of 11 (permalink) Old 01-26-10, 10:23 AM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 7
Re: Parking brake indicator

i think there is a problem in the fluid level switch. one of the purple in white wires is supposed to be grounded when the key is first turned on and one is supposed to be grounded when the float goes down, but neither are grounded with float up and both grounded with float down, so i'm thinking there is a short in the switch between those two legs.
ElliottsAuto is offline  
post #9 of 11 (permalink) Old 01-26-10, 11:27 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,298
Re: Parking brake indicator

That wouldn't affect the park brake light circuit.

Bert
Bert is offline  
post #10 of 11 (permalink) Old 01-26-10, 11:31 AM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 7
Re: Parking brake indicator

i figured it out. two problems. the parking brake switch was intermittently not working which threw my testing off. and the wire going from the switch to the light circuit was grounded on the switch side, and open on the light side. and the reason i thought the bulb check wasn't working is because it does the bulb check when cranking the car, not when the key first turns on. so i replaced the switch and re-wired it. all is good now. thanks for the help.
ElliottsAuto is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome